恒美微站
首页
关于我们
建站服务
主题模板
案例展示
资讯中心
联系我们
docker离线安装mysql镜像
首页
资讯中心
/
docker离线安装mysql镜像
docker离线安装mysql镜像
发布时间:2026/10/9 2:58:02
1、离线下载mysql镜像包并拷贝到需要安装的linux环境目录下安装包地址链接: https://pan.baidu.com/s/1SZ-VPHltam69FySB68lV9g?pwd3i8s 提取码: 3i8s将mysql571.gz拷贝到home目录下2、安装mysql2.1、进入mysql安装包目录cd /home/2.2、加载mysql镜像docker load -i mysql571.gz2.3、查看镜像docker images2.4、创建mysql容器docker run -d --name mysql -p 3306:3306 -e MYSQL_ROOT_PASSWORD123456 --restart always c20987f18b13执行命令如下图参数解释-d 表示在让容器后台运行–name 给容器起一个名字-p 3306:3306 把宿主机的3308端口port映射到Mysql容器的3306端口-e MySQL 容器的环境配置MYSQL_ROOT_PASSWORD123456 指定mysql根用户的密码用户名默认为root注意如果没有指定密码会启动失败。–restart always挂掉后重启c20987f18b13镜像的IMAGE ID2.5、查看容器操作容器2.5.1、进入mysql容器bash交互界面docker exec -it mysql bash2.5.2、登录mysqlmysql -u root -p2.5.3、修改root远程连接权限切换数据库mysql use mysql给root用户授权mysqlgrant all privileges on.to ‘root’‘%’ identified by ‘123456’ with grant option;退出mysqlexit;2.5.4、远程连接mysql连接成功可以进行数据库操作了。额外补充若启动报错OCI runtime create failed: container_linux.go:349: starting container process caused “process_linux.go:449: container init caused “write /proc/self/attr/keycreate: permission denied””: unknown可能的原因是系统安全模块限制解决方案如下检查 SELinux 状态主要针对 CentOS/RHEL 系统getenforce如果输出为Enforcing强制模式可临时切换为宽容模式测试setenforce0重新尝试启动容器如果问题解决说明是 SELinux 限制导致。可通过以下方式永久解决编辑 SELinux 配置文件vi /etc/selinux/config 将SELINUXenforcing改为SELINUXpermissive 重启系统生效或保持临时宽容模式